Jump to content

Archived

This topic is now archived and is closed to further replies.

faz

[Résolu] maxthon 3.3.5.1000 : bug user-agent avec page google

Recommended Posts

jai un gros bug avec la page google avec moteur webkit (avec moteur ie9 ca marche tres bien).

 

1/ quand je suis sur google que je clique dans le champ de recherche, déjà le curseur ets décalé vers le haut du champs.

 

max3-1.jpg

 

2/ quand je tape du texte dans le champ de recherche, la recherche auto de google se met en marche mais ca bug a mort ! :

 

max3-2.jpg

 

3/ enfin si je cliquer sur le bouton bleu sur la page google pour lancer la recherche manuellement : rien !

et ca met une adresse bizarre dans la barre d'adresse de maxthon3.

 

http://www.google.fr/#hl=fr&output=search&sclient=psy-ab&q=maxt&pbx=1&bav=on.2,or.r_gc.r_pw.r_qf.,cf.osb&fp=25fb525c14b1e7e9

 

max3-3.jpg

Share this post


Link to post
Share on other sites

jai modifié l'user agent qui était sur "internet explorer9" en selectionnant les autres et en testant 1 par 1.

 

resultat : quand useragent est sélectionné sur internetexplorer 6 7 8 ou 9 ca bug.

 

quand user agent = maxthon, firefox, chrome, safari... ca marche.

 

il y a un souci...

Share this post


Link to post
Share on other sites

Bonjour

 

Ce n'est pas un bug, c'est tout à fait logique, pour faire simple en utilisant le mode ultra avec le UserAgent IE cela ne peut pas marcher correctement, c'est pour cela qu'il existe un mode retro qui correspond à IE.

En fait c'est comme si tu disais au site j'ai un navigateur IE donne moi le code pour IE alors qu'en fait il a un navigateur webkit en face de lui qui n'interprète pas le code de la même manière que IE

 

C'est pour cela que maxthon utilise 2 modes différents.

 

IE ne respecte pas les recommandations du W3C (par exemple sur les marges internes et externes), c'est pour cela qu'il lui faut un mode particulier, pour IE9 c'est un peu moins vrai, microsoft a fait des progrés.

 

Pour les autres navigateurs qui respectent mieux ces recommandations, le useragent est un peu moins important même si on peut tomber sur quelques différences.

 

Donc non ça n'est pas un souci, c'est un comportement tout à fait normal, si tu veux un userAgent IE9 tu utilises le mode retro qui est fait pour cela. C'est justement un plus de Maxthon.

 

A+

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.