Jump to content

Archived

This topic is now archived and is closed to further replies.

Jimi

retro / turbo mode

Recommended Posts

J'ai constaté qu'un de mes essai de plugin ne fonctionnait pas en turbo mode, or il est impossible de switcher le mode manuellement pour les plugins.

Mais je viens de trouver cela :

Some older web pages, not written for newer standards, are distorted, have features that don’t work, don’t display at all, or even crash other browsers. Usually Maxthon 3 will recognize these pages and automatically switche to Retro Mode, designed for those older pages.
Reste a trouver quoi mettre dans la page pour qu'il switche tout seul donc.

J'ai fait tout un tas de tentavives ( en lecture normale dans le browser ), mais toutes infructueuses.

Si qqun rencontre un jour une page qui switche toutes seule , il faudrait le signaler, en décortiquant cette page , je trouverais bien ce qu'il faut alors ....

Share this post


Link to post
Share on other sites

Salut Jimi

 

Tu as essayé en ajoutant une balise meta à ton html du style <meta http-equiv="X-UA-Compatible" content="IE=edge" />

On utilises souvent ce genre de truc pour forcer certains modes au boulot car on a du IE6 et du IE8 et donc des problèmes de temps en temps.

 

Un lien où tu pourras trouver des infos http://msdn.microsoft.com/fr-fr/library/cc...5(v=vs.85).aspx

 

A+

Share this post


Link to post
Share on other sites
Salut Jimi

 

Tu as essayé en ajoutant une balise meta à ton html

 

Pas mieux wink.png Je sais plus dans quel contexte je l'ai utilisé, mais ça marche très bien !

 

EDIT : Ah si, c'était avec mon filtre Facebook il y a quelques temps, à l'heure où j'utilisais IE8 et IE9 sur 2 PC différents !

Share this post


Link to post
Share on other sites
hmmm

j'ai essayé pleins de balises meta justement mais pas celle la, je vais tester illico

 

edit : je viens de tester sur : http://jimi27.free.fr/j-radios/radios.htm

 

keutch sad.png

Si tu changes de mode de rendu en cliquant sur l'éclair, le mode de rendu est conservé par Maxthon pour ton site, ce qui fait que si tu y retournes, même après avoir fermé et relancé Maxthon, il ouvre ton site désormais toujours en mode Rétro. :)

 

Par contre, dans le volet latéral des Plugins, je ne sais pas si c'est la même logique ? -^-

Share this post


Link to post
Share on other sites
As-tu essayé en mettant un <!DOCTYPE> valide ?

 

A+

 

ou sans doctype du tout, ca devrait etre considéré comme une page old school ^^

 

j'ai aussi un peu cherché comment forcer le mode retro mais sans succés.

Share this post


Link to post
Share on other sites

oui j'ai essayé un tas de doctype et avec aucun aussi.

Si je demande ici, c'est bien parceque je suis a court d'idée ...

Share this post


Link to post
Share on other sites
oui j'ai essayé un tas de doctype et avec aucun aussi.

Si je demande ici, c'est bien parceque je suis a court d'idée ...

 

Là je n'ai pas trop d'idée, car en général c'est la balise que l'on utilise au boulot pour forcer l'interprétation au niveau navigateur.

Si j'ai le temps je ferai des tests, demain, mais je ne te garantie rien, c'est ma dernière semaine avant mon départ à la retraite donc j'ai pas mal de choses à faire.

 

sm5.gif

Share this post


Link to post
Share on other sites

Salut

 

J'ai continué ma recherche et fait quelques tests, mais aucun de probant.

Il semblerait en fait que ce soit le serveur qui se configure pour forcer le mode de rendu, j'ai trouvé des fichiers de config pour forcer le mode IE7 par exemple

 

"Configuring Web Servers to Specify Default Compatibility Modes

 

Site administrators can configure their sites to default to a specific document compatibility mode by defining a custom header for the site. The specific process depends on your web server. For example, the following web.config file enables Microsoft Internet Information Services (IIS) to define a custom header that automatically renders all pages in IE7 mode."

 

<?xml version="1.0" encoding="utf-8"?>
<configuration>
 <system.webServer>
<httpProtocol>
  <customHeaders>
	<clear />
	<add name="X-UA-Compatible" value="IE=7" />
  </customHeaders>
</httpProtocol>
 </system.webServer>
</configuration>

J'ai également testé des hacks sans résultat, désolé.

 

Il faudrait peut-être poser la question aux développeurs sur le forum anglais, pour savoir comment on peut forcer le mode IE.

 

A+

Share this post


Link to post
Share on other sites

Attendez, je pige pas, si la page à ça comme en-tête :

<head>

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

</head>

 

Ce n'est pas le mode retro qui s'active alors ? (on peut tester aussi avec IE=5 pour forcer le bignou)

 

Je vais essayer de trouver une page où Max v3 swith tout seul en mode retro, pour voir quel élément le pousse à switcher wink.png Après, il suffira de le leurrer !

Share this post


Link to post
Share on other sites
Attendez, je pige pas, si la page à ça comme en-tête :

 

 

Ce n'est pas le mode retro qui s'active alors ? (on peut tester aussi avec IE=5 pour forcer le bignou)

 

Je vais essayer de trouver une page où Max v3 swith tout seul en mode retro, pour voir quel élément le pousse à switcher wink.png Après, il suffira de le leurrer !

 

Justement j'ai testé ce matin en forçant avec IE5 et ça ne change rien, Jimi avait déjà essayé.

 

En fait le mode compatibilité que l'on peut forcer par des balises meta est fait pour forcer IE à un mode particulier (5 6 7 ou 8) mais pas à basculer en mode rétro, la subtilité est là.

 

A+

Share this post


Link to post
Share on other sites

Pour la liste des sites normalement "retro" c'est la liste officielle de microsoft, il suffit avec un éditeur de texte (wordpad par exemple) d'éditer C:\Program Files\Internet Explorer\iecompat.dll, il y a une partie xml qui donne la liste, mais j'en ai également testé quelques une et max ne bascule pas en mode rétro. blush.png

Share this post


Link to post
Share on other sites

j'ai bien l'impression que la fontion de switchage auto est désacitvée ...

whistling.gif

On perd notre temps, faudrait demander confirmation sur le fofo officiel ( en invoquant le fait que c'est pour faire des plugins peut etre ... )

Share this post


Link to post
Share on other sites

je viens de lancer pour la premiere fois l'url:

http://ie.microsoft.com/testdrive/Performa...nk/Default.html

 

et il active automatiquement le mode "rétro" pour l'afficher :

 

en regardant la source, la seule balise présente est bien :

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

 

Je suppose qu'elle doit fonctionner pour passer automatiquement en mode retro.

Share this post


Link to post
Share on other sites
Je suppose qu'elle doit fonctionner pour passer automatiquement en mode retro.

 

Ah, je dis pas que des conneries quand même ! :angelic: Je pense que ça venait de Max v3, il faut utiliser une version à jour :s:

 

Tu nous tiens au courant Jimi !

Share this post


Link to post
Share on other sites
Ah, je dis pas que des conneries quand même ! :angelic: Je pense que ça venait de Max v3, il faut utiliser une version à jour :s:

 

Tu nous tiens au courant Jimi !

 

C'est bien le meta que j'avais donné à jimi au tout début de ce fil, mais à priori d'après ses tests et les miens cela ne forçait pas le passage en mode rétro, donc ......ben je ne sais pas.

 

Ou alors si j'ai bien compris ce que tu veux dire, c'est que le non passage en mode rétro serait dû à une des versions de max ?

 

En tout cas le site donné par rip_it active bien le mode retro pour la version 3.1.2.1000, je vérifierai au boulot demain la version que j'utilise.

A+

Share this post


Link to post
Share on other sites

je confirme que le lien de rip_pit ( after me , :s: je sors ) passe bien en rétro mode auto, sans que j'ai eu a changer de version.

par contre c'est pas la balise meta que j'avais deja essayee et viens de retenter encore.

ya autre chose sur la page ( et peut etre invisible, si code php ... )

En tout cas on en tient une apparement.

Share this post


Link to post
Share on other sites

Bon je viens de tester : Maxthon v3 (dernière version) passe bien en mode retro selon la liste officielle (Microsoft) des sites nécessitant le mode compatibilité.

 

Exemple :

 

http://www.microsoft.com/fr-fr/default.aspx -> Mode Retro

Par contre son miroir : http://www.maxthon-fr.com/10ours/test.html -> Mode Turbo

De plus, avant même de charger la page, l'icone Mode Retro s'affiche, cela prouve que c'est basé sur l'URL et non le code de la page :s:

Share this post


Link to post
Share on other sites

je me doutais d'un truc comme ca ... en focntion de l'URL

le terme "passage auto" est donc un gros bobard ... grrrr

Share this post


Link to post
Share on other sites
Bon je viens de tester : Maxthon v3 (dernière version) passe bien en mode retro selon la liste officielle (Microsoft) des sites nécessitant le mode compatibilité.

 

Exemple :

 

http://www.microsoft.com/fr-fr/default.aspx -> Mode Retro

Par contre son miroir : http://www.maxthon-fr.com/10ours/test.html -> Mode Turbo

De plus, avant même de charger la page, l'icone Mode Retro s'affiche, cela prouve que c'est basé sur l'URL et non le code de la page :angelic:

 

argh! une liste de sites gérée par microsoft ?? :angelic:

on la trouve ou cette liste j'aimerai bien y jeter un oeil :angelic:

et savoir comment faire pour y rajouter l'url de la page à jimi :angelic::s:

Share this post


Link to post
Share on other sites

non, moi j'ai compris que c'etait les developpeurs de max qui tenaient a jour une liste de sites a eviter en turbo ...

et les sites de microsoft font partie de cette liste

( on fait patte de velour tant qu'on se sert encore du moteur krosoft ... et en meme temps pour dire que krosoft va moins vite que max ,

haaa les supplices chinois ..... )

Share this post


Link to post
Share on other sites

De plus, la liste d'URL a afficher en mode Rétro est cryptée, on ne peut donc pas l'utiliser ou la modifier.

 

Quoi qu'il en soit, je suis à peut près certains que le volet latéral des n'utilise ni le tueur de pubs, ni la détection du mode Rétro. :s:

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.