Jump to content

Archived

This topic is now archived and is closed to further replies.

Ldfa

Internet Explorer 9 en version finale

Recommended Posts

Salut Pierre !

 

Je ne peux pas reproduire tes test car tu as un écran de dingue et une carte graphique bien supérieure à la mienne !! :hola:

 

En 1680 x 920 avec 1000 poissons je suis à 32 FPS pour IE9 et Max v2... Donc de mon côté je pense être limité par les composants de mon ordi alors que tu sembles limité (avec Maxthon) par une clé qui bloque l'utilisation de toutes tes ressources... Si je trouve d'où cela peut venir je reviens te le dire !

 

Si tu as le temps, peux-tu tester en réduisant la taille de ta fenêtre, aux alentours de 1600x900 (ce paramètre est indiqué colonne de droite quand on lance le site de test) ?

Dans cette situation, obtiens-tu les mêmes résultats avec Maxthon et IE9 ?

 

Pour ma part :

Carte graphique : Nvidia 8800 GT 512 Mo

Ecran 22"

 

De dingue ??

 

il ne faut pas exagérer , la carte graphique a bien trois ans !! mon écran est un ACER T230H 23 pouces tactile.

 

 

bon en 1600*900 même phénomène :

 

IE9 : 47 fps, 80%

MAX2 : 32 fps, 55%

 

Il semblerait que le moteur sature à 47 fps , il ne monte pas ( ressources < 1920*1080 )

 

si je baisse la fenêtre en 640*480 , IE9 donne toujours 47-48 , seules les ressources baissent à 60 %, Max2 toujours 32 et 40% .

 

 

 

Au travail maintenant !!

Share this post


Link to post
Share on other sites
Au travail maintenant !!

 

:hola:

 

Quand tu pourras, tu me communiqueras les résultats de tes test, cette fois avec 20 poissons :hola: (j'essaie d'éliminer des pistes)

 

Merci à toi !

Share this post


Link to post
Share on other sites
:hola:

 

Quand tu pourras, tu me communiqueras les résultats de tes test, cette fois avec 20 poissons :hola: (j'essaie d'éliminer des pistes)

 

Merci à toi !

 

Le Problème c'est qu'à 20 poissons je suis au taquet ( 60 !! ), il n'y a pas de valeur au dessus !

 

la différence se fait sentir à partir de 500 poissons ou je dois me dé-scotcher légèrement de 60 , je ne vois réellement une différence qu'à partir de 1000 poissons.

 

pb de "riche" !!

Share this post


Link to post
Share on other sites
Le Problème c'est qu'à 20 poissons je suis au taquet ( 60 !! )

 

Ah, ça c'est très bon signe !!

 

Merci pour l'info. :hola: Je vais fouiller, voir si je trouve un truc... c'est pas gagné !

Share this post


Link to post
Share on other sites
Ah, ça c'est très bon signe !!

 

Merci pour l'info. :hola: Je vais fouiller, voir si je trouve un truc... c'est pas gagné !

 

Bon,mais d'un autre coté ce n'est pas critique puisqu'il est clair que les fonctions GPU sont utilisées ( au moins en grande partie ), j'ai fait le test avec la dernière Beta de Max2 et la dernière de Max3.

 

il faudrait que je compare avec un autre benchmark de la série , mais je ne sais que choisir ( j'aime bien "Psychedelic Wheel").

Share this post


Link to post
Share on other sites
Bon,mais d'un autre coté ce n'est pas critique puisqu'il est clair que les fonctions GPU sont utilisées ( au moins en grande partie ), j'ai fait le test avec la dernière Beta de Max2 et la dernière de Max3.

 

il faudrait que je compare avec un autre benchmark de la série , mais je ne sais que choisir ( j'aime bien "Psychedelic Wheel").

 

 

Bon , je me reponds tout seul !

 

 

avec "Psychedelic browser test" , j'observe une différence significative à l'avantage d'ie9

Share this post


Link to post
Share on other sites
Une petites question, faut il comme pour ie8 proteger certains clé ou on peux les laisser comme elles sont ?

 

Merci

Tu veux parler des clés que Maxthon modifie à chaque démarrage ? :s:

Share this post


Link to post
Share on other sites

Oui c'est ca ldfa. Doit on les proteger comme pour ie8.

 

Aussi je viens de faire le test des poissons et il me mets sur le moteur de ie8 car il me demande d'installer ie9 alors qu'il est deja installer !

 

Par contre je suis entre 60 et 100fps dans le test, pourquoi il ne note pas ie9...

Share this post


Link to post
Share on other sites

Je pense que sur ce coup là, Dixours est le plus à même pour te répondre, car je n'ai pas encore installé IE9.:s:

Share this post


Link to post
Share on other sites

Salut !!

 

- Alors, pour ce qui est de IE8/IE9, ce sont ces 2 clés qui indiquent la version du moteur :

 

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]

"Maxthon.exe"=dword:00002328

 

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_DOCUMENT_COMPATIBLE_MODE]

"Maxthon.exe"=dword:00002328

 

Vérifies aussi que dans le Centre de Configuration de Maxthon (onglet "Avancé"), la case user Agent est décochée et que "Utiliser le mode de rendu standard de IE9" est coché.

 

Avec ça, il devrait indiquer que tu utilises IE9 ;)

Si ce n'est toujours pas le cas, alors il faudra vérifier que IE9 a bien fait son travail quand tu l'as installé, c'est à dire qu'il a bien modifier une autre clé de registre (je te l'indiquerai si besoin il y a)

 

- 2ème point : la protection des clés.

 

Je ne suis pas certain que les clés doivent être protégées avec cette nouvelle version de Maxthon (v2.5.18.200-beta2) car j'ai fait l'essai et les clés n'ont pas été modifiées au redémarrage de Maxthon. Cependant, je n'ai pas tenté de redémarrer carrément mon ordi, et comme je les ai maintenant protégées, difficile d'être certain dans un sens ou un autre... Dans le doute, personnellement, je pense qu'il vaut mieux les protéger mais c'est un avis personnel :s:

 

Tiens nous au courant surtout !

Share this post


Link to post
Share on other sites
Salut !!

 

- Alors, pour ce qui est de IE8/IE9, ce sont ces 2 clés qui indiquent la version du moteur :

 

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION]

"Maxthon.exe"=dword:00002328

 

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_DOCUMENT_COMPATIBLE_MODE]

"Maxthon.exe"=dword:00002328

 

Vérifies aussi que dans le Centre de Configuration de Maxthon (onglet "Avancé"), la case user Agent est décochée et que "Utiliser le mode de rendu standard de IE9" est coché.

 

Avec ça, il devrait indiquer que tu utilises IE9 ;)

Si ce n'est toujours pas le cas, alors il faudra vérifier que IE9 a bien fait son travail quand tu l'as installé, c'est à dire qu'il a bien modifier une autre clé de registre (je te l'indiquerai si besoin il y a)

 

- 2ème point : la protection des clés.

 

Je ne suis pas certain que les clés doivent être protégées avec cette nouvelle version de Maxthon (v2.5.18.200-beta2) car j'ai fait l'essai et les clés n'ont pas été modifiées au redémarrage de Maxthon. Cependant, je n'ai pas tenté de redémarrer carrément mon ordi, et comme je les ai maintenant protégées, difficile d'être certain dans un sens ou un autre... Dans le doute, personnellement, je pense qu'il vaut mieux les protéger mais c'est un avis personnel :s:

 

Tiens nous au courant surtout !

Merci pour les info dixours.

Cela fonctionne maintenant, le probleme est que je n'avais pas installer MX 2.5.18.200 et donc il n'utilisait pas le moteur ie9 !

Par contre pourquoi on ne peux utiliser la chaine user agent ?

Et aussi doit on laisser utiliser le zoom de ie7 ?

 

Merci

Share this post


Link to post
Share on other sites
Par contre pourquoi on ne peux utiliser la chaine user agent ?

Et aussi doit on laisser utiliser le zoom de ie7 ?

 

Merci

Salut !

 

1) Si si, tu peux utiliser la chaine User Agent, je te l'ai fait décocher uniquement pour éliminer cette source potentielle d'erreur pour ton problème (IE8/IE9) précédent :angelic:

Remarque : je ne vois pas bien l'intérêt pour un usage classique de cocher cette case maintenant... A moins que tu souhaites volontairement brider certaines fonctions ? Par exemple, si tu veux tromper Google, tu peux utiliser cet user Agent :

 

Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.0; Maxthon 2.0)

 

(Windows NT 6.0 c'est pour ceux qui ont Vista, comme moi, sinon c'est 6.1 pour Seven :angelic: )

 

L'intérêt, c'est de désactiver des fonctions Google :

- Lors d'une recherche, un clique gauche sur un résultat n'affiche plus l'aperçu.

- Lors d'une recherche d'images, c'est l'ancienne galerie Google (sans Javascript) qui s'affiche au lieu de la nouvelle.

 

Pour les curieux : Quand on décoche la case User Agent, c'est le User Agent par défaut de Maxthon qui est utilisé, c'est à dire :

 

Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.0; Trident/5.0)

 

(Windows NT 6.0 c'est pour ceux qui ont Vista, comme moi, sinon c'est 6.1 pour Seven :) )

 

2) Moi je n'ai pas coché la case Zoom de IE7 et le zoom fonctionne très bien... Je pense que cette fonction est utile seulement pour ceux qui ne mettent pas à jour Internet Explorer et qui en sont restés à IE7 ;)

Share this post


Link to post
Share on other sites
L'intérêt, c'est de désactiver des fonctions Google :

- Lors d'une recherche, un clique gauche sur un résultat n'affiche plus l'aperçu.

- Lors d'une recherche d'images, c'est l'ancienne galerie Google (sans Javascript) qui s'affiche au lieu de la nouvelle.

 

moi je trouve ca pas mal du tout le clic gauche pour l'apercu smile.png))

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.