Jump to content

Archived

This topic is now archived and is closed to further replies.

lian

Envoyer url par mail

Recommended Posts

Puisque je sens que Jimi est chaud, je vais lui exposer un mini problème agaçant. Je suis passé à Pocomail pour mon courrier (TB devrait prendre quelques leçons de facilité d'utilisation dommage qu'il soit chèros) mais bizarrement, il n'arrive pas à être géré par IE7 ou Maxthon pour la commande "envoyer URL par mail" dans le menu fichier. Il est bien déclaré par défaut dans les options de programme de IE7, il fonctionne avec mailto (enfin !) et la fonction marche bien avec TB quand je mets ce dernier par défaut. Où est-ce que je pourrais farfouiller dans la base de registre pour vérifier ça ? (j'ai fait une recherche Google mais ça ne m'a pas trop aidé).

Share this post


Link to post
Share on other sites

Chez moi en XP, c'est déclaré en :

HKEY_CLASSES_ROOT\mailto

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto ( mais en principe en changeant celui au dessus, celui la devrait suivre auto )

et

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

 

[HKEY_CLASSES_ROOT\mailto]
@="URL : Protocole MailTo"
"EditFlags"=dword:00000002
"URL Protocol"=""
[HKEY_CLASSES_ROOT\mailto\DefaultIcon]
@="\"D:\\APP\\NET\\_NET\\PHOENIX\\Phoenix.exe\",0"
[HKEY_CLASSES_ROOT\mailto\shell\open\command]
@="\"D:\\APP\\NET\\_NET\\PHOENIX\\Phoenix.exe\" -newmail \"%1\""


[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
@="Phoenix Mail"
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Phoenix Mail]
@="Phoenix Mail"
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Phoenix Mail\Protocols\mailto]
@="URL:MailTo Protocol"
"Edit Flags"=hex:02,00,00,00
"URL Protocol"=""
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Phoenix Mail\Protocols\mailto\DefaultIcon]
@="\"D:\\APP\\NET\\_NET\\PHOENIX\\Phoenix.exe\",0"
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Phoenix Mail\Protocols\mailto\shell\open\command]
@="\"D:\\APP\\NET\\_NET\\PHOENIX\\Phoenix.exe\" -newmail \"%1\""
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Phoenix Mail\shell\open\command]
@="\"D:\\APP\\NET\\_NET\\PHOENIX\\Phoenix.exe\""

 

Pour HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail yen a d'autres, j'ai fais le menage la, mais la 1ere ligne :

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]

@="Phoenix Mail"

 

Prends le pas sur les autres

 

PS : Ne cherchez pas a utiliser Phoenix aussi, c'est le plus pourri du marché, mais avec lui RIEN ne passe, meme un peu trop aux gouts de tous. Vous n'aimerez pas c'est clair. Mais il n'execute rien, meme un mail en html il me l'affiche en texte en me fout le fichier html en piece jointe. Pour moi un mail c'est fait pour écrire, point final.

Share this post


Link to post
Share on other sites

Arf

Ca ne marche pas avec Max2 icon1.gif

 

"This function need MAPI"

Qui est MAPI ?

 

et lian rappelles moi qui a dit qu'il n'y avait pas de bugs dans Maxthon 2 ?

Par contre c'est nickel en v159 bien sur ;)

Share this post


Link to post
Share on other sites

Et hop ;) petit coup de pub pour le plugin que j'avais créé y'a qq temps : Sendmail.

Share this post


Link to post
Share on other sites

Ca ne marchera pas en v2, car les numéros de commandes ont changés ... grrr

Il te faut ouvir le fichier "sendmail.htm" avec le notepad et tu remplaces 32988 par 33333

Moyennant quoi chez moi il me reclame toujours MAPI ...

Share this post


Link to post
Share on other sites

Ben je ne vois rien dans les plugin du centre de config et je n'ai pas de nouvelle icone qui apparaisse...

Share this post


Link to post
Share on other sites

Je n'ai jamais testé ce plugin en v2 (vu que je suis un peu réfractaire à la v2 pour l'instant)

Share this post


Link to post
Share on other sites

J'ai eu un doute et j'ai fait un test avec Firefox: la fonction fonctionne bien sous FF2. Me voilà encore plus perplexe :-)

Share this post


Link to post
Share on other sites
Si c'est un activeX non installé, cela expliquerait que ça fonctionne sous FF et pas sous Max

Oui, bon, TB se lance très bien lorsqu'on le met par défaut alors je ne suis pas convaincu...

Share this post


Link to post
Share on other sites
Oui, bon, TB se lance très bien lorsqu'on le met par défaut alors je ne suis pas convaincu...

J'utilise le même logiciel de messagerie et j'ai le même problème. ;)

Share this post


Link to post
Share on other sites

Bon, dans ce cas là, ce n'est pas de la faute de ma config, c'est déjà ça de gagné :-) Merci pour cette confirmation Ldfa.

Share this post


Link to post
Share on other sites

Je pense que je me suis mal fait comprendre, lorsque l'on utilise le client MAPI d'outlook, on utilise un activeX, donc pour FF ou autre browser, il faut un autre client MAPI, qui je pense ne sera pas un activeX.

Je pense que comme cela c'est plus clair ;)

Share this post


Link to post
Share on other sites

tain, je viens de trouver un truc terrible, chuis pas loin de faire le plugin du coup. Et ce sera mieux car pas besoin de client mail ni de MAPIchose.

Mon idée est d'ouvir un onglet, de choisir dans une liste déroulante un destinatire, un clic sur un bouton, et l'url de la page en cours part aussi sec ! ( un peu le principe et le look, de mon plugin Googla (voir screen ) )

 

ca vous branche ?

 

edit : ce qui est fort, c'est que je viens de faire un test. Mon FAI est Orange et je viens d'envoyer un mail par Laposte a une autre de mes adresse Laposte, sans besoin du login et pass. !!

Arf Je viens de mettre la main sur l'outil idéal pour spammeurs quoi lol

 

edit : le nom est tout trouvé deja ==> SPAMIT

LOLLLLL

Share this post


Link to post
Share on other sites
tain, je viens de trouver un truc terrible, chuis pas loin de faire le plugin du coup. Et ce sera mieux car pas besoin de client mail ni de MAPIchose.

Mon idée est d'ouvir un onglet, de choisir dans une liste déroulante un destinatire, un clic sur un bouton, et l'url de la page en cours part aussi sec ! ( un peu le principe et le look, de mon plugin Googla (voir screen ) )

 

ca vous branche ?

Moi je veux bien faire testeur :-)

Share this post


Link to post
Share on other sites

Allez, c'est parti

 

Pour le nom je deconnais, tu m'entrouve un qui va bien ? ansi qu'un icone ? ( une ? LOLLLLL )

 

 

edit : c'est bon j'ai tout, ca marche deja

J'ai trouvé un zoli icoen ici meme sur ce forum

Et le nom sera simplement MailTo

 

Ca va etre cool

 

- Choix du destinataire en liste

- Message ou pas avant

- url ou pas

- Message ou pas apres

- Log de suivi d'envoi du mail

- Possibilite d'envoyer a plusieurs contacts d'un seul coup ( y compris soi-meme pour verif par exemple )

 

Du coup on pourras s'en servir pour envoyer un mail avec ou san l'URL de la page en cours

 

PS : un certain Jimi n'arrete pas de m'écrire ????

Share this post


Link to post
Share on other sites

Un petit test à faire Jimi, tu enleves le mot de passe de ton client mail et ensuite tu testes, car ça me parait bien louche quand-même de pouvoir envoyer sans login/mot de passe

Share this post


Link to post
Share on other sites
Un petit test à faire Jimi, tu enleves le mot de passe de ton client mail et ensuite tu testes, car ça me parait bien louche quand-même de pouvoir envoyer sans login/mot de passe

Ca m'etonnerait, car j'utlilise un soft de mail, qui ne s'installe pas , et les logins et pass sont encryptés grave dans un fichier.

Par contre mon FAI est Orange, et depuis peu, Pour envoyer un mail ( avec qq autres boites que ce soit ... laposte ...etc ) il faut parametrer le seveur d'envoi en "smtp.orange.fr", ( qui n'apparait pas dans le mail recu ), le mail transite par orange en qq sorte. J'en sais pas trop plus, juste que Orange et Free sont les 2 seuls a pratiquer ainsi.

 

Mais seront prevus pour ceux qui en on besoin, l'authentification stockées ou non, au choix de l'utilisateur. (Je viens juste d'y penser)

 

En fait pour tout dire , j'ai trouvé un freeware ( un seul fichier exe ) en ligne de commande, que je vais piloter via le plugin de facon totallement transparente. Et ses possibilités sont immenses, tout est prevu, dingue, meme les pieces attachées. Je ne sais pas d'ailleurs si c'est necessaire que j'exploite tout ... On verras suivant les demandes eventuelles des gens. La je part sur des fonctions basiques comme je decrivais plus haut.

Share this post


Link to post
Share on other sites
Ca m'etonnerait, car j'utlilise un soft de mail, qui ne s'installe pas , et les logins et pass sont encryptés grave dans un fichier.

Par contre mon FAI est Orange, et depuis peu, Pour envoyer un mail ( avec qq autres boites que ce soit ... laposte ...etc ) il faut parametrer le seveur d'envoi en "smtp.orange.fr", ( qui n'apparait pas dans le mail recu ), le mail transite par orange en qq sorte. J'en sais pas trop plus, juste que Orange et Free sont les 2 seuls a pratiquer ainsi.

 

Bizarre, je suis également chez orange, et le serveur sortant a toujours été smtp.orange.fr (sauf avant orange c'était smtp.wanadoo.fr).

Je comprends d'autant moins que pour envoyer ou recevoir il faut ouvrir une session sur le serveur smtp et donc login mot de passe.

 

Autre exemple, avec mon client mail, je relève également mon courrier sur gmail j'ai donc un autre compte configuré avec comme smtp smtp.gmail.com et là encore il faut une ouverture de session avec login/mdp donc je ne vois pas bien comment cela peut marcher sans ça.

 

Dernier point, que tu utilises un client qui ne s'installe pas ne change rien au problème, tu le dis toi même tu as un fichier login/mdp crypté donc il se peut trés bien que le fichier soit utilisé à l'insu de ton plein grés au moment de l'envoi.

 

;););)

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.